Suzuki LT-R450 Forum :: LTR450HQ.com banner
1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I need the sealed electrical connector on the wiring harness that attaches to the throttle position sensor. It's grey with three wires into it. Mine is destroyed and I want to just rewire a new one into the existing wiring harness instead of replacing the entire harness for just one connector. A new or used wiring harness isn't cheap.

I've looked at alpha sports and none of the electrical connectors look like this one. Google searches have been worthless because I don't even know what "style" of connector for which to search.
I've tried releasing the wires inside of the connector with a small pick, but couldn't even get that.

Where can I find a replacement TPS connector?
What "style" or type of connector is it?
Am I just going to have to buy a new wiring harness?

Any help would be much appreciated.
 

Attachments

·
Registered
Joined
·
1 Posts
I to have this problem. I've tried soldering the red, black and yellow wires directly to the male studs coming from the tps sensor. It seemed like it worked for a min and my indicator light turned off. It soon came back on and bike ran like strait shit again. My dumbass also somehow stripped the threads for the bolt that fastens the tps to the throttle body. I tried tapping it but then drilled a pin sized hole through into the venturnie. So that is a thin wall there fellas. 😐 not that anyone here would or could do such a foolish thing.
I'm in the market for a throttle body by the way guys. Pretty pricey for new o.e.m. put if I had to, I would fork it out.
Poor things been sitting in my buddy's garage for a whole week now.😖
 
1 - 4 of 4 Posts
Top