Suzuki LT-R450 Forum :: LTR450HQ.com banner
81 - 100 of 130 Posts

·
Registered
Joined
·
3 Posts
I have a 06 450 with yoshi exhaust and cherry bomb. To get it to start i have to hold the throttle about half way down and it still takes a good 20 seconds to start but if i roll start it with the throttle half way it fires right up. Any help would be greatly appriciated.
thanks
same problem here any help
 

·
Registered
Joined
·
117 Posts
Could be your valves out of spec
 

·
Registered
Joined
·
195 Posts
I need to find a new map for my power commander. I just removed the trinity exhaust and the fuelatv intake. its running only the 12.8:1 piston now with a 110/92 fuel mix. Cant get it to idle right with the current map or with the PCIII unplugged. on start up the throttle sticks at a pretty high rpm, rev few times goes down. if i touch the throttle it bogs and dies.
 

·
Registered
Joined
·
19 Posts
fast idle lever

i have an '08 LTR thats having trouble starting , i have to use three hands to get it going. it seems that the fast idle cable has stretched out. i have to hold down the fast idle lever with force, push the start button and give it 1/4 throttle to get it to fire up. then it wont idle till its nice and warmed up, if i dont use the fast idle it takes 20-30 seconds for it to even fire and then its hit and miss if it'll stay running. i was thinking of removing the fast idle and using the (yosh) block off plug ? the fast idle lever seems slack like theres no resistance pushing it thru its range of motion ....

also was thinking about going to a stage one cam set .... yes/no ?

looking for a steering stem, stock or aftermarket +2 w/ 1 1/8 clamp
 

·
Registered
Joined
·
8 Posts
i got a new fuel pump and had my injector tested and its still wont start with out starting fulid and i took the swirl filter out
 

·
Premium Member
Joined
·
28,672 Posts
no It's not,, it's in my sig, lol
 

·
Registered
Joined
·
12 Posts
ok i have a 06 ltr that i was having trouble starting, some times it was fine and other times it would do a half a turn and stop like the battery was dead. i rod it in to the shed then put it away and the next time i went to start it the motor just turns ove freely like it has no compresson. wont even start with starting fluid what could thid be?
 

·
Registered
Joined
·
4 Posts
Ok have read thru here don't see answer. I have a 06 yosh stage 3 with pipe cherry bomb exc. Have a hard time getting it started, have to give it about 1/2 throttle and will finally start. When it is warm will start easier but still have problems. The motor has 15 hours since full rebuild. Any thoughts?
 

·
Registered
Joined
·
25 Posts
I have a starting issue, I am less than 5 hours from a full rebuild, and the mechanic told it was the compression relese? I was wondering how to test it? It will start and run fine but when hot, if i kill it it wont crank fast enough to restart and when cold it cranks slow but starts
 
81 - 100 of 130 Posts
Top