Suzuki LT-R450 Forum :: LTR450HQ.com banner

1 - 6 of 6 Posts

·
Registered
06 ltr450
Joined
·
7 Posts
Discussion Starter #1
Was out riding when i lost electricity to the hole bike! If i let it sit then turn it on the power will come back on but no fuel pump an theres a click sound when i hit the starter then the power cuts back out. Anybody ever had this problem or know why its doing this?
 

·
Registered
06 ltr450
Joined
·
7 Posts
Discussion Starter #2
Figured out it got hot first time i ran a hot plug. If you got an thing to add to this plz do id like to know. I got this bike suppost to be like new its been ran but how far idk only thing i can think is it does this. Ive heard of running a performance propellar an waterless collant with no thermo idk imput plz. thx
 

·
Registered
06 ltr450
Joined
·
7 Posts
Discussion Starter #3
Figured out it got hot first time i ran a hot plug. If you got an thing to add to this plz do id like to know. I got this bike suppost to be like new its been ran but how far idk only thing i can think is it does this. Ive heard of running a performance propellar an waterless collant with no thermo idk imput plz. thx
 

·
Registered
06 ltr450
Joined
·
7 Posts
Discussion Starter #4
Can i check impeller? is there stamping on it? I dont want to tear it down so i dont ruin my investment! These days Almost Like New bike is hard to come by!
 

·
Registered
06 ltr450
Joined
·
7 Posts
Discussion Starter #5
Also is waterless coolant what ive heard its suppost to be idk seems artifical, like normal coolant its the mixture! Whats better? IDK
 

·
Registered
06 ltr450
Joined
·
7 Posts
Discussion Starter #6
Also bike has a Cherry Bomb (yoshimura). Do you think it could be rodehard, Idk, I took it out this weekend an it had a temper the last five mins of riding. but mid ride it wanted to race my nutz off 3hrs or so. If this was an all day race id be dead in the water!
 
1 - 6 of 6 Posts
Top