Suzuki LT-R450 Forum :: LTR450HQ.com banner

1 - 10 of 10 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
today i went for a ride as i started my ltr it took about 3 starts before it would acutely stay started usually it stays started on the first start which it's not to big of a concern to me because after i got it warmed up it started right up like always, but when i took off i noticed it was boging out at close to full throttle. the other day it did the same to me but stoped after i shut it off and restarted it so i figured maybe bad gas. i just got the whole top end rebuild about 6 months ago so im sure all that stuff should be just fine i really hope so, and i have no starting problems. but i while back i pulled out my swirl filter and it was pretty dirty, and i cleaned it out a lil. i ordered a new filter and o-ring for it now but just barley got it yesterday and have not put it in yet so im hoping maybe it will help along with a new spark plug, but if not dose anyone have any idea of what it could be? or have ever had this problem?
 

·
Registered
Joined
·
58 Posts
Start with a compression test. That will tell you a lot! When was the last time you checked valves I thought valve will give you those symptoms.
 

·
Registered
Joined
·
58 Posts
By doing that it will rule out motor. Also check timing chain and count the links to make sure it's in time. If that dosent take care of it then check fuel pressure and look at your spark to make sure it's strong. Plus checking valve lash is maintainence anyway, good luck
 

·
Registered
Joined
·
141 Posts
Discussion Starter #5
yea im hoping its just my swirl filter.i just finished taken the tank off, emptyed it out cleaned it, and took my swirl filter apart, cleaned it up, and put in the new filter and a new o-ring. cost was $60.00 bucks just for the two, also i took the cockpet off the tank and cleaned those lil injectors out. im thinking off taking the fuel pump off in the morning and cleaning out the hose that connect from it to the injectors i sean a bit of dirt particles in their so im going to try and pull off the fuel pump, but iv never don it dose anyone have any advise on it? also is it possible to clean out the fuel pump? if so is it difficult or simple? is their any type of fuelter in the fuel pump that should be replaceed? and advise would haelp. also i just did a rebuild 6 months ago everything except lifters, springs, cams, and time chain. only did new cylinder, piston, valves, cylinder head, shims. any advise about the rebuild would be appropriated also.
 

·
Registered
Joined
·
2,783 Posts
you are going to need to clean the filter in your fuel pump. And test your fuel pressure to figure out your problems or you are just guessing what is wrong. This situation has been discussed a hundred times before. Use the search you will find your answers
..
 

·
Registered
Joined
·
141 Posts
Discussion Starter #7
im pretty sure i have solved my problem i hope so anyways i only took my LTR for a 2 min test ride because its dark and my neighbors might get mad but it ran with no bogging i hope tomorrow when i test ride it longer the pump or anything don't decide to make it bogg out again. my worry is that the pump had these 2 days to rest an maybe tomorrow when i ride for a while it will start giving out you know what i mean.. the reson i worry about the pump is because i never did a fuel pressure test so im not sure if the pump is week or starting to take a crap, but im hoping the pump was never the issue because i finished replacing the lil strainer inside my swirl filter i cleaned the entire swirl filter and hoses, i pulled my fuel pump off and took it apart cleaned it and the lil filter inside, it seamed pretty clean, i pulled off the (fuel cockpet/ injectors) and looked down each one to make sure they were not cloged up they were clean. cleaned every fuel line out they had lil grains of dust but not anything serious. i also put in a new spark plug i went from a (NGK R, CR7E to a NGK R, CR8E) i put fresh gas in. she start up fine and ran fine, but again it was only a 2 min ride. i hope everything stays good. thanks for everyones help and advise it always helps alot.
 

·
Registered
Joined
·
7 Posts
yea im hoping its just my swirl filter.i just finished taken the tank off, emptyed it out cleaned it, and took my swirl filter apart, cleaned it up, and put in the new filter and a new o-ring. cost was $60.00 bucks just for the two,...
I replaced my swirl filter with just a regular in-line filter which is much cheaper to replace every so often. Only $3.95. Just a thought for next time!
 
1 - 10 of 10 Posts
Top