Suzuki LT-R450 Forum :: LTR450HQ.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi, I'm new to the forum, from Manchester UK. I have a 2006 ltr 450, just got a question... I have a dual thumb/twist throttle fitted. When riding, the throttle response is really good but when throttle is released the revs don't drop off immediately, leaving me having to wait, be it maybe a second, to change gear. Pretty sure this isn't normal, maybe incorrect throttle cable adjustment or a sticky cable? The thumb and twist mechanisms return straight away when let go of. Any advice appreciated
 

·
Registered
Joined
·
21 Posts
You need to check cable adjustment. Turn in the cable adjuster on the Dual gasser and try it. If that solves it, you will need to fine tune the cable adjustment. You did not say if the thumb throttle does the same thing or not. The cable too tight would cause both the concern you are having.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for your reply. I've since stripped down and found a slight kink in the cable causing it to drag on the outer cable sheath. Removed throttle body and operated flap by hand, that is also slow to close. Cleaned with carb cleaner and has helped a little. Built back up, the problem is almost gone. I imagine the spring in TB has gone weak? Is this common? Guess if I want it perfect it'll be a new TB.
 

·
Registered
Joined
·
2,775 Posts
How do you like that throttle? Do you have any pictures of it mounted?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I don't have a picture, but I'll be honest with you, I don't like the twist throttle. I prefer thumb. The bike had this on when I bought it. It does look pretty up on the bars though
 
1 - 5 of 5 Posts
Top