Suzuki LT-R450 Forum :: LTR450HQ.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, I have raced two wheels my whole life and finally decided to make the switch to four so I went and got me an 06 LTR. (my wallet isn't near as excited as I am, quickly discovering twice the wheels means twice the money) Anyway, the bike sat up for a long time before I got it due to the one way bearing going out and the previous owner having plenty of other toys. With a new one way bearing and a few minutes of work I had it back up and running... almost. The bike cranks very easily and runs at idle fine but when any throttle is applied it dies. I've let it run at idle for a while and it also gets very hot very fast. My knee jerk was too much air so I pulled the filter and choked it out with a towel which seemed to work well but only when I restricted almost all air flow. Not really sure what to do next, I have never worked with fuel injection and am now at a stand still. Now for the engine details: Athena 490cc big bore, stage three hot cams, fmf powerbomb header, Yoshi RS-5 pipe, Yoshi PIM-2 programmer, Yoshi cherry bomb, and no airbox with a K&N filter. Any direction would be very helpful. Thank you!
 

·
Registered
Joined
·
130 Posts
The EFI can be very touchy. There are a lot of threads on here about bogging or low fuel pressure. Basically you have to tear into the EFI system and test things one by one with the process of elimination. It's fairly easy just time consuming and annoying. I really have learned to hate the quick connects under the tank as they can be a pain sometimes. I just went through a mysterious bog this spring and it ended up being an old sparkplug that was on it's way out. Start small with the basics, then move into your EFI system. Search the forums for bogging...

If I had to guess, I would say your injector is clogged....
 

·
Super Moderator
Joined
·
31,830 Posts
Hi, I have raced two wheels my whole life and finally decided to make the switch to four so I went and got me an 06 LTR. (my wallet isn't near as excited as I am, quickly discovering twice the wheels means twice the money) Anyway, the bike sat up for a long time before I got it due to the one way bearing going out and the previous owner having plenty of other toys. With a new one way bearing and a few minutes of work I had it back up and running... almost. The bike cranks very easily and runs at idle fine but when any throttle is applied it dies. I've let it run at idle for a while and it also gets very hot very fast. My knee jerk was too much air so I pulled the filter and choked it out with a towel which seemed to work well but only when I restricted almost all air flow. Not really sure what to do next, I have never worked with fuel injection and am now at a stand still. Now for the engine details: Athena 490cc big bore, stage three hot cams, fmf powerbomb header, Yoshi RS-5 pipe, Yoshi PIM-2 programmer, Yoshi cherry bomb, and no airbox with a K&N filter. Any direction would be very helpful. Thank you!
Ok to start with you need to clean the entire fuel system. flush out the tank and hoses and pump with fresh fuel. May need to do it a couple times. also when you drain the old out, look for water in the fuel. once everything is flushed out it would be a good idea to replace the swirl filter and clean the screen in the injector and the one in the fuel pump. then test your fuel pressure. You need to have 42 psi when primed and when running if you are low, you will need either a new fuel pump or fuel psi regulator. when you get your pressure correct and everything is clean, you are going to want to make sure your fuel map is correct. a Dyno tune will confirm your Air/Fuel ratio.

Also you may want to do a little checking on what mods if any are really done. If you were told you had a stage 3 hotcams, its possible you don't even have a bigbore. Hotcams only made a stage one cam set for the LTR.

Welcome to the site.
 
1 - 3 of 3 Posts
Top