Suzuki LT-R450 Forum :: LTR450HQ.com banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have an 2006 ltr450 that I think has a bad battery because if I put the battery on a trickle charger and let it charge up and then put it into my 4Wheeler it will start up and drive for a while and then it suddenly cuts off and then it won't start again and I can keep repeating that "charging the battery and putting it back in" and it works every time I get one good start out of the battery then the 4Wheeler cuts off and it won't start again but it will start if I bump start it and it runs perfectly fine but then this last time when I got done riding it I parked it in the garage and when I came back a little later I noticed that it was dripping gas out the little rubber nipple on the bottom of the airbox and it didn't stop dripping until my whole gas tank was empty If anyone knows what could cause this any help would be very appreciated I'm kind of a newbie to this whole 4Wheeler thing
 

·
Super Moderator
Joined
·
1,309 Posts
Sounds like your injector is not closing and allowing it to drain out.
 
  • Like
Reactions: Joshua

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks I'm going to try that today and I'll let you know, I also had another friend tell me that.... do you think it would be possible to just clean it and put it back in or do you think I'm gonna need to get a new one if it's not closing would cleaning it fix it just enough to test it maybe?
 
1 - 3 of 3 Posts
Top