Suzuki LT-R450 Forum :: LTR450HQ.com banner

starting problems

  1. Slow crank/ maybe binding??

    Engine/EFI/Drivetrain
    Okay so I rebuilt the top end got it all back together and it would not start. check valves probably 20 times so there good. new battery passed load test. all connections are good. timing is correct. I also took the magneto cover off bc we let the timing chain get loose and come off and the...
  2. Ltr not starting and backfiring PLEASE HELP!!

    Member Introductions
    I have an 07 and just had it rebuilt by a reliable mechanic. I took the motor out and re-installed. Its not throwing any codes, exhaust is not leaking, intake is off so i can get to the throttle body. When i crank it over it wont start and backfires threw the intake and exhaust. The machine ran...
  3. newbie just traded for my first ltr but it wont stay on please help! Hardstart...

    Engine/EFI/Drivetrain
    So I just traded my yz426 dirtbike for an 06 ltr450 that is having issues. Heres the story on it... started smoking on the previous owner & slow starting so he dropped of at a guy that worked out of his house to have the top end rebuilt with a 480 bigbore or something like that. 7 months later...
  4. hard to start/hard to idle/alote of black smoke

    Engine/EFI/Drivetrain
    my ltr is acting all wierd, just rebuilt the engine. new piston new transmission, timing is at 15 teeth valves are at clearance tolerances, i checked all wiring all sensors, took the throttle body out checked it. It is hard to start, once started iddling is very hard have to hold throttle, and...
  5. Starter Clutch/ Keyway Problem

    Engine/EFI/Drivetrain
    Got my '06 ltr fixed finnallllyyy!! I haven't been able to start my quad for almost a year and was worried I would have to spend too much money in the shop to get her fixed. I took it in and found that the key way was worn down and not engaging the starter clutch. I had the starter clutch...
  6. Starting problems... Valves??

    Engine/EFI/Drivetrain
    Ive got an 06 ltr. And problems. it will not start by means of electric start. it will pull start though. (behind another fourwheeler) i had plug boot problems before with the same symptoms. i checked mine, it was broke so i replaced it, and the plug. no progress. is there anyway that it could...
  7. turn over but no start

    Engine/EFI/Drivetrain
    I just bought an 06 which is stock except for the yosh pipe and cherry bomb. It has not been ridden heavily since new. I am having problems starting it though. When i push the electric start the engine will turn over but just wont fire. It runs if i push start it but i would rather not do that...
  8. Starting Problems

    Engine/EFI/Drivetrain
    I have seen a couple of guys with starting issues -- let's try to use this thread. I went out this weekend for my second ride. After my first break -- tried to start -- NOTHING. Battery power - yes -- BUT No starter turning. I checked the fuse... thought about the roll-over switch. I found...
Top