Fan not working/lights don't light up sometimes - Suzuki LT-R450 Forum :: LTR450HQ.com
Problem Solved! Read-only forum of archived threads with identified fixed problems

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-13-2015, 07:27 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Nov 2015
Posts: 3
View Derekq13's Photo Gallery(0)
Exclamation Fan not working/lights don't light up sometimes

I have a 2008 LTR-450 that I just bought recently. I haven't really rode it much but the other day I noticed the bike was hot and the fan never turned on. I kept riding and then then the bike stalled out on me, I tried turning the key to fire it up again but the lights weren't working, they didn't light up so I couldn't turn it on. The bike was probably overheated, which I know is really bad, so I let it sit. after a while of sitting the lights came back on when I turned the key but I tried starting it and it just made a clicking sound and the lights turned off again. I don't know what the problem could be but I'm guessing bad fuses? Water temp sensor? Idk, I'm really bad with electronics on these bikes and stuff lol. let me know what you guys think!!!! Thank you.
Derekq13 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-14-2015, 05:10 AM
Super Moderator
Premium Member
Feedback Score: 2 reviews
 
CQR's Avatar
 
Join Date: Nov 2006
Location: Denver, CO
Posts: 31,830
View CQR's Photo Gallery(1)
Sounds like a bad connection or possibly an overcharged/bad battery. Not sure where you are from, but around here this time of year my fan seldom comes on.

Four (4) '06 LTR450's, '16 Beta 300RR, '09 CRF150RB, '11 Grizzly 550, 16 Beta X trainer, Laeger Trx500


canyontackfeed.com
www.morrisoncarworks.com
www.sodalakestable.com
CQR is offline  
post #3 of 4 (permalink) Old 12-14-2015, 12:42 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Nov 2015
Posts: 3
View Derekq13's Photo Gallery(0)
Quote:
Originally Posted by CQR View Post
Sounds like a bad connection or possibly an overcharged/bad battery. Not sure where you are from, but around here this time of year my fan seldom comes on.
Ok thank you, might be and connection. I'm not riding it until I get the fan fixed which I still am not %100 sure what the problem is.
Derekq13 is offline  
post #4 of 4 (permalink) Old 03-22-2016, 09:30 AM
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jan 2016
Posts: 14
View jperez4's Photo Gallery(0)
I got the same problem my fan won't come on even after the temperature light comes one. Checked the fuses and nothing looks wrong.
jperez4 is offline  
Reply

  Lower Navigation
Go Back   Suzuki LT-R450 Forum :: LTR450HQ.com > LTR450 Tech Discussion > Problem Solved!

Tags
battery, fan, fuses, lights, stalling

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki LT-R450 Forum :: LTR450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome