Problems with fuel injector not getting power - Suzuki LT-R450 Forum :: LTR450HQ.com
General Discussion Talk about anything on your mind here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-03-2018, 10:30 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Bikelife3's Avatar
 
Join Date: Sep 2017
Posts: 4
View Bikelife3's Photo Gallery(0)
Problems with fuel injector not getting power

So, I took apart whole bike and put it back together. I'm not getting power to injector. I cleaned wiring harness when it was apart. Things I've tried already. Tip over sensor siliconeed, tried three different injector plugs, fuel is making it to the injector but not spraying when I turn the key on. The bike did fire up when I sprayed steering fluid in the intake. Fuel pump is coming on when I turn the key. Tps sensor is good and working as it should. 0.66 I believe was the number. Need help finding problem. Thanks in advance.
Bikelife3 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Suzuki LT-R450 Forum :: LTR450HQ.com > LTR450 Headquarters > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki LT-R450 Forum :: LTR450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just bought 05 with big bore kit, problems already... kalvina General Discussion 15 05-07-2018 09:55 AM
Fuel pressure regulator tests good but is bad kdsd731 Engine/EFI/Drivetrain 17 04-29-2018 05:34 PM
No power to relay for fuel pump 06 Pumas Body/Controls/Protection 9 01-18-2018 06:49 AM
I'm so stumped. No power to the Fuel pump Lunaticracer723 General Discussion 4 06-02-2016 07:30 AM
Burnt clutch, now no power to starter or fuel pump JLMax16 Engine/EFI/Drivetrain 1 01-18-2016 12:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome