LTR 450 dies when given throttle. - Suzuki LT-R450 Forum :: LTR450HQ.com
Engine/EFI/Drivetrain Discuss engine, fuel injection, air intake, and drivetrain modifications here

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-08-2019, 01:43 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jun 2019
Posts: 1
View TylerES's Photo Gallery(0)
Question LTR 450 dies when given throttle.

My ltr 450 was running good so i ended up buying a athena 100mm big bore kit. got everything back together the quad starts and idles good but when given any throttle it bogs for a second then dies. i put gas down the lines to get any air pockets out and still doesnt seem to be working. what do you think?
TylerES is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-07-2019, 01:54 PM
Junior Member
Feedback Score: 0 reviews
 
Luckysevens's Avatar
 
Join Date: Aug 2019
Posts: 3
View Luckysevens's Photo Gallery(0)
Have you adjust the fuel to compensate for the new bore?
Luckysevens is offline  
Reply

  Lower Navigation
Go Back   Suzuki LT-R450 Forum :: LTR450HQ.com > LTR450 Tech Discussion > Engine/EFI/Drivetrain

Tags
help won't run, ltr 450, ltr 450 problem, problem

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki LT-R450 Forum :: LTR450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome