Won’t rev above idle! Bad ECU or FI? - Suzuki LT-R450 Forum :: LTR450HQ.com
Engine/EFI/Drivetrain Discuss engine, fuel injection, air intake, and drivetrain modifications here

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-24-2018, 10:18 AM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Afterlife975's Avatar
 
Join Date: Nov 2018
Posts: 4
View Afterlife975's Photo Gallery(0)
Won’t rev above idle! Bad ECU or FI?

I bought a 2007 ltr450 a few months ago that will start and run but won’t rev up it bogs and dies. So far I went through the fuel system I did the swirl filter delete, checked I was getting the right fuel pressure past the regulator & I even cleaned the injector & Still nothing. So I went and check the tps and set it to the right range. I did a leak down test on the valves and it holds great no bleeding and I even get good compression. I also just put a brand new iap on and still no change. I’m at the point of thinking it the eco but don’t want to shell out a bunch of cash for one to have the same problem. Has anyone experienced the same issue?
Afterlife975 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-24-2018, 07:48 PM
pcs
Senior Member
Feedback Score: 8 reviews
 
pcs's Avatar
 
Join Date: Jun 2009
Location: yuma,az
Posts: 1,752
View pcs's Photo Gallery(11)
what psi did u get before injector and how did u clean injector

2006 Ltr 450 ron woods exh,cp piston,webs, Lectron 46mm carb, racerz edge head, slc +4 swinger, metal tech a arms, marvin shocks.
1985 Yamaha Tri Z: cool head,vf 3, 39 pwk, dynoport exh, bartlette racing port, metal tech +2 swinger
1982 Honda 250r: answer exh, vm32, moss reeds, wiseco piston, +2 swinger.
2011 suzuki hayabusa: brocks street meg exh, k/n, pc5
pcs is offline  
post #3 of 7 (permalink) Old 11-25-2018, 08:02 AM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Afterlife975's Avatar
 
Join Date: Nov 2018
Posts: 4
View Afterlife975's Photo Gallery(0)
Wont rev above idle! Bad ECU or FI?

I got 43 psi with 88ml on the flow test. I used a aerosol can fuel injector cleaner you hook the injector to 12v and pulse the spray.
Afterlife975 is offline  
post #4 of 7 (permalink) Old 11-25-2018, 06:03 PM
pcs
Senior Member
Feedback Score: 8 reviews
 
pcs's Avatar
 
Join Date: Jun 2009
Location: yuma,az
Posts: 1,752
View pcs's Photo Gallery(11)
u can pull injector out of tb and crank engine and watch spray pattern should be a fine mist. bad ecu might not even run. mine did the same (symptoms) ended up being injector. had it rebuilt then good to go

2006 Ltr 450 ron woods exh,cp piston,webs, Lectron 46mm carb, racerz edge head, slc +4 swinger, metal tech a arms, marvin shocks.
1985 Yamaha Tri Z: cool head,vf 3, 39 pwk, dynoport exh, bartlette racing port, metal tech +2 swinger
1982 Honda 250r: answer exh, vm32, moss reeds, wiseco piston, +2 swinger.
2011 suzuki hayabusa: brocks street meg exh, k/n, pc5
pcs is offline  
post #5 of 7 (permalink) Old 11-25-2018, 06:14 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Afterlife975's Avatar
 
Join Date: Nov 2018
Posts: 4
View Afterlife975's Photo Gallery(0)
Wont rev above idle! Bad ECU or FI?

Alright sounds good I’m gonna order a new Keihin stock size injector right now and hopefully that will fix my problem
Afterlife975 is offline  
post #6 of 7 (permalink) Old 11-29-2018, 08:31 AM
pcs
Senior Member
Feedback Score: 8 reviews
 
pcs's Avatar
 
Join Date: Jun 2009
Location: yuma,az
Posts: 1,752
View pcs's Photo Gallery(11)
i sent mine to get rebuilt. mine had new pump and fpr and go pressure. had a bad spray pattern. frustrating

2006 Ltr 450 ron woods exh,cp piston,webs, Lectron 46mm carb, racerz edge head, slc +4 swinger, metal tech a arms, marvin shocks.
1985 Yamaha Tri Z: cool head,vf 3, 39 pwk, dynoport exh, bartlette racing port, metal tech +2 swinger
1982 Honda 250r: answer exh, vm32, moss reeds, wiseco piston, +2 swinger.
2011 suzuki hayabusa: brocks street meg exh, k/n, pc5
pcs is offline  
post #7 of 7 (permalink) Old 12-03-2018, 09:16 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Afterlife975's Avatar
 
Join Date: Nov 2018
Posts: 4
View Afterlife975's Photo Gallery(0)
Wont rev above idle! Bad ECU or FI?

Update.... I put the new injector in and it will rev up if you ease into the throttle. But if you nail the throttle off idle it bogs any ideas?
Afterlife975 is offline  
Reply

  Lower Navigation
Go Back   Suzuki LT-R450 Forum :: LTR450HQ.com > LTR450 Tech Discussion > Engine/EFI/Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki LT-R450 Forum :: LTR450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
08 won’t start just backfires Noah_loethen Engine/EFI/Drivetrain 1 06-04-2018 07:43 AM
Fuel pressure regulator tests good but is bad kdsd731 Engine/EFI/Drivetrain 17 04-29-2018 05:34 PM
New to forum; 2008 ltr 450 idle problems Bubsy Engine/EFI/Drivetrain 2 08-15-2017 06:40 AM
Erratic idle. Stapes Engine/EFI/Drivetrain 6 04-05-2017 11:18 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome