FI light illuminated randomly - Suzuki LT-R450 Forum :: LTR450HQ.com
Engine/EFI/Drivetrain Discuss engine, fuel injection, air intake, and drivetrain modifications here

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-31-2016, 02:51 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jul 2016
Posts: 12
View Darkheaven2007's Photo Gallery(0)
FI light illuminated randomly

Its a 07' ltr450 with two brothers slip on, yoshi power bomb module, and no air box lid.
Turn key on and FI light is some times with engine not running.
Engine running at idle light might be on then turns off or stays on. With engine at idle riding with just the clutch the FI light sometimes turns off.
Riding with the throttle it seems like the first 1/8" of the throttle is un responsive then has rpm spike. This symptom does not have an FI light.

While at an idle if i stab the throttle to 1/2 to 3/4 it "coughs"/ hesitates a second.

Help would be greatly appreciated since my dealer isnt an option due to fee's and honesty
Darkheaven2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-01-2016, 08:08 AM
Member
Feedback Score: 0 reviews
 
Join Date: Feb 2015
Posts: 52
View Alucard's Photo Gallery(0)
If your EFI light stays on then your running in a down graded mode. There is an issue but not a bad one that could cause engine damage. You need to put the bike in dealer mode to get the code to find out what sensor is giving you trouble. I would check your OAT temp sensor in the air box, it may be broke.
Alucard is offline  
post #3 of 8 (permalink) Old 08-02-2016, 05:41 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jul 2016
Posts: 12
View Darkheaven2007's Photo Gallery(0)
The plug in on the harness im looking for to do. " dealer mode" is the same one the cherry bomb is plugged into?
Darkheaven2007 is offline  
post #4 of 8 (permalink) Old 08-03-2016, 05:49 AM
Member
Feedback Score: 0 reviews
 
Join Date: Feb 2015
Posts: 52
View Alucard's Photo Gallery(0)
Yeah, ground the white/red wire.
Alucard is offline  
post #5 of 8 (permalink) Old 08-03-2016, 07:56 AM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jul 2016
Posts: 12
View Darkheaven2007's Photo Gallery(0)
Ok, do i touch it once or keep it grounded the entire time during the dealer mode with the engine not running key on?
Darkheaven2007 is offline  
post #6 of 8 (permalink) Old 08-03-2016, 08:15 AM
Premium Member
Premium Member
Feedback Score: 0 reviews
 
shadey's Avatar
 
Join Date: Jan 2007
Location: Chandler AZ
Posts: 28,644
View shadey's Photo Gallery(0)
Look in the manual, they use a switch to make the contact with the red/white wire. you can just ground the wire to make that connection.

Quote:
Originally Posted by hinkle View Post
We started hitting the teens but no white stuff yet.
2006 LTR 535-R, Go Big or Go Home.


Her name is Bruce

https://www.ltr450hq.com/forums/gener...ce-manual.html
https://onedrive.live.com/?authkey=%...%21147&o=OneUp

LTR450 manual ^ ^ ^ ^ ^ ^
shadey is offline  
post #7 of 8 (permalink) Old 08-03-2016, 11:58 AM
Member
Feedback Score: 0 reviews
 
Join Date: Feb 2015
Posts: 52
View Alucard's Photo Gallery(0)
Just leave it connected while getting the codes. What I have done on mine is use wire taps and setup a switch that is located in the air box, so should I need to put it in dealer mode, I can do it any time without have to take the plastics off.
Alucard is offline  
post #8 of 8 (permalink) Old 08-04-2016, 10:27 AM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
Join Date: Jul 2016
Posts: 12
View Darkheaven2007's Photo Gallery(0)
Well I am going to start with saying thank you for all the help. But the problem wasn't what I thought it was it was the fuel light was switched with the FI light and the fuel level was making my FI light turn on and blink randomly. The previous owner must have nocked them out of the sockets and didnt know where they went.
Without the PDF service manual on this forum i wouldnt have noticed the
FI and the fuel light were mixed up.
Once again thanks for the help
Darkheaven2007 is offline  
Reply

  Lower Navigation
Go Back   Suzuki LT-R450 Forum :: LTR450HQ.com > LTR450 Tech Discussion > Engine/EFI/Drivetrain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki LT-R450 Forum :: LTR450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
LED light bar wiring tigman186 General Discussion 4 05-26-2016 09:50 PM
Red Light 06 Ltr450 Dasmon420 General Discussion 2 04-25-2016 08:15 PM
mount for led light pod 1320king General Discussion 0 02-17-2016 11:58 AM
Light weight mark94 General Discussion 3 02-03-2016 08:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome