ECU Mapping Problem? - Suzuki LT-R450 Forum :: LTR450HQ.com
Dyno/Tuning Room Post all your dyno and fuel injection tuning information here!

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-08-2018, 02:07 PM Thread Starter
Junior Member
Feedback Score: 0 reviews
 
xmac23g's Avatar
 
Join Date: Jul 2018
Posts: 3
View xmac23g's Photo Gallery(0)
Question ECU Mapping Problem?

HELP PLEASE. 2006 450 LT-R Suzuki. I just replaced all the following items with brand new parts: ProCom ECU/EFI unit, Voltage rectifier, Coil, OEM Fuel Pump, Stator by Moose Racing, OEM Key Ignitition Switch, New Tether Switch, New Spark Plug, Head Gasket and Piston rings. Piston is stock. Motor work by Williams Performance (head ported & polished) I also deleted the swirl filter and replaced with a straight in line fuel filter. PROBLEM: Bike starts up fine, has good compression. Runs fine in all gears at low rpm's, than when you hammer the throttle to 80-100% it takes off for about 3-5 seconds before the engine shuts down. I have set the ECU unit on all the pre set maps that ProCom sets # 's 4,5,6,7,8 and it does the same thing. Map # 9 the bike will not stay running. Any help would be greatly appreciated as I have spent a ton of money on parts so far. Does this sound like an issue of mapping?
xmac23g is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-10-2018, 07:35 AM
Super Moderator
Premium Member
Feedback Score: 2 reviews
 
CQR's Avatar
 
Join Date: Nov 2006
Location: Denver, CO
Posts: 31,830
View CQR's Photo Gallery(1)
Is your fuel pressure constant when it starts to die out?

Four (4) '06 LTR450's, '16 Beta 300RR, '09 CRF150RB, '11 Grizzly 550, 16 Beta X trainer, Laeger Trx500


canyontackfeed.com
www.morrisoncarworks.com
www.sodalakestable.com
CQR is offline  
Reply

  Lower Navigation
Go Back   Suzuki LT-R450 Forum :: LTR450HQ.com > LTR450 Tech Discussion > Dyno/Tuning Room

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki LT-R450 Forum :: LTR450HQ.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Major Problem - New Discovery - Help from KMS kennerz Engine/EFI/Drivetrain 2 12-20-2017 07:19 AM
Bog problem solved thumper450 Problem Solved! 1 07-25-2016 06:31 PM
2006 Ltr 450 valve problem Deezaljoones Engine/EFI/Drivetrain 5 07-10-2016 07:25 PM
Low speed, engine problem michanio91 Engine/EFI/Drivetrain 18 03-11-2016 02:12 PM
starting problem ltr450fied69 Member Introductions 8 12-09-2015 05:36 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome